Elitehost - Network Issues – Incident details

Network Issues

Resolved
Operational
Started over 7 years agoLasted about 6 hours
Updates
  • Resolved
    Resolved

    Thank you for your patience, the network has been stabilised, we are monitoring closely for any further service disruptions.

  • Identified
    Identified

    We are observing a DDoS attack against our network. The issue is being mitigated by engineers and we will post further updates here as soon as we have them.

  • Investigating
    Investigating

    Apologies for the inconvenience, we are currently experiencing degraded network performance. Our network engineers are working to get this issue resolved.