Scheduled Server Maintenance - rs27 and cp34
Scheduled for 03 April, 2026 at 10:01 PM – 04 April, 2026 at 1:37 AM
Affects
Web Hosting Services
Under maintenance from 10:01 PM to 1:37 AM
Completed
04 April, 2026 at 1:37 AMCompleted
04 April, 2026 at 1:37 AMThe maintenance has been completed. Thank you for your patience.
In progress
03 April, 2026 at 10:01 PMIn progress
03 April, 2026 at 10:01 PMMaintenance is now in progress
Planned
03 April, 2026 at 10:01 PMPlanned
03 April, 2026 at 10:01 PMWe are performing maintenance on rs27 and cp34
Start: Saturday 4th April 2026 - 00:01 SAST (GMT+2)
End: Saturday 4th April 2026 - 04:00 SAST (GMT+2)
During the scheduled maintenance window, your website and email services will be temporarily offline for approximately 3 hours.