Degraded Performance - Cloud Infrastructure
Incident Report for Elitehost
Resolved
Thank you for your patience, services have been restored.

We are busy monitoring the Cloud infrastructure for any further issues.
Posted over 1 year ago. Mar 27, 2018 - 12:23 SAST
Investigating
Apologies for the inconvenience caused.

We are experiencing degraded performance on our Cloud infrastructure.
We are working to get services restored as soon as possible
Posted over 1 year ago. Mar 27, 2018 - 11:31 SAST