Lets Encrypt DST Root CA X3 Expiration
Incident Report for Elitehost
Resolved
This incident has been resolved. Thank you for your patience during this time.

Some browsers and mail clients may report still these certificates as invalid because of the expired certificate in their local trust chains. Please contact our support if you still experience issues.
Posted Oct 02, 2021 - 13:56 SAST
Monitoring
Let's Encrypt related issues should now be mostly resolved. Some browsers and mail clients may report still these certificates as invalid.

The solution is to re-issue any certificates having issues via cPanel -> SSL/TLS Status -> Run AutoSSL (tick all). It may take up to 15 minutes for the new certificate to take effect. There are also some cases where reissuing Let's Encrypt is rate-limited due to increased demand on their infrastructure as a result of this.

We’re sorry this is happening. We did not expect it to happen, but we’re working hard to resolve any remaining issues.
Posted Oct 01, 2021 - 14:10 SAST
Identified
A change was made by Let's Encrypt, an organization that issues free SSL certificates. One of their intermediate certificates, used by browsers and other software to verify the issued certificates, expired yesterday, September 30th.

Some browsers and applications, such as mail clients, may report these certificates as expired or invalid.

We have rolled out a patch to affected cPanel servers and are in the process of reissuing affected certificates.

Thank you for your patience during this time.
Posted Oct 01, 2021 - 11:32 SAST