Cloud Maintenance
Incident Report for Elitehost
Resolved
We have successfully completed this maintenance window.

Thank you for your patience and understanding.
Posted over 1 year ago. May 20, 2018 - 04:19 SAST
Identified
We are performing scheduled software upgrades on our cloud infrastructure. You may experience brief intermittent connectivity issues during this maintenance window. Apologies for the inconvenience caused.
Posted over 1 year ago. May 19, 2018 - 20:34 SAST