ZACR Registry Issues
Incident Report for Elitehost
Resolved
This has been resolved. Our connection to the ZACR domain registry has been restored.
Posted 9 months ago. Jan 09, 2019 - 15:09 SAST
Identified
We are currently experiencing connection issues with the ZACR registry. This affects new registrations, renewals, and management of .co.za, .capetown, .joburg, .durban and .africa TLDs. Existing domains will continue to resolve normally.
Posted 9 months ago. Jan 09, 2019 - 14:46 SAST
This incident affected: Domain Services.