Site Builder Offline
Incident Report for Elitehost
Resolved
The issue has been resolved and access to the site builder has been restored. Apologies for the inconvenience caused.
Posted Oct 25, 2021 - 02:08 SAST
Identified
We are currently experiencing a technical issue with our site builder. The site builder is currently unavailable as a result.

We are currently working to restore functionality and will keep you updated.

We apologise for any inconvenience this may cause.
Posted Oct 24, 2021 - 22:40 SAST
This incident affected: Web Hosting Services.