Client Area Maintenance
Incident Report for Elitehost
Resolved
The maintenance has been completed. Thank you for your patience. Please email helpdesk@elitehost.co.za if you experience any issues.
Posted about 1 year ago. Sep 09, 2018 - 07:10 SAST
Identified
Our client area will be undergoing maintenance this evening. We apologise for any inconvenience that this may cause. The maintenance window will run until 4am.

During the maintenance window the client area login will be disabled. Should you require assistance with your services during this time please feel free to reach out to our support team at helpdesk@elitehost.co.za

Please contact us if you have any questions. Thank you for your continued support and patience.
Posted about 1 year ago. Sep 08, 2018 - 20:21 SAST
This incident affected: Client Area.