Elitehost - Degraded Performance - Cloud Infrastructure – Incident details

Degraded Performance - Cloud Infrastructure

Resolved
Degraded performance
Started over 6 years agoLasted about 1 hour
Updates
  • Resolved
    Resolved

    Thank you for your patience, services have been restored. We are busy monitoring the Cloud infrastructure for any further issues.

  • Investigating
    Investigating

    Apologies for the inconvenience caused. We are experiencing degraded performance on our Cloud infrastructure. We are working to get services restored as soon as possible