We are performing maintenance on RS04
Incident Report for Elitehost
Resolved
Maintenance has been completed successfully and all services are functioning as expected.

Please email helpdesk@elitehost.co.za if you experience any issues after the maintenance window.
Posted about 2 years ago. Oct 13, 2017 - 20:23 SAST
Identified
Customers may be unable to connect to websites on this server during the maintenance window.
Posted about 2 years ago. Oct 13, 2017 - 20:05 SAST